The issues affecting the Sync platform have been resolved. All systems are back to normal and you should no longer experience any of the previously reported disruptions.
Thank you for your patience while our team worked through this! As always, don't hesitate to reach out if you notice anything further.
Posted Jul 20, 2026 - 15:09 EDT
Identified
We want to keep you informed — our team has identified an issue following our latest deployment that is currently impacting the Sync platform. You may notice slower load times, order recheck failures, repeated refreshes needed to update information, or occasional "Internal Server Error" messages. Rest assured, our dev team is already on it and working toward a fix. We'll keep you posted with updates as soon as we have them. Thank you for your patience!
Posted Jul 20, 2026 - 14:51 EDT
This incident affected: Sync Application (Sync Application UI, Distribution and Processing, Transfers, Crawls. Transferless Delivery & Mobile QR Creation).